HomeMicrosoft


Unable to search some addresses in Streets and Trips 2009, 2010
jackyca
I can not search by street No# and street name in versions 2009 or 2010.

For example:

  • 1800 Eglinton Ave East, Toronto
  • 30 Seneca Hill Dr, Toronto

But when I use old edition like 2007, it's working fine.

Is there any solution for this issue? Thanks.
Marvin Hlavac
Hi jackyca,

Make sure you are searching Canada (not U.S.).
jackyca
Hi ,Thanks Marvin.

Yes, I did search in Canada,Toronto as well. still can not find it.system pops up please make sure your address i correctly something.
I found this issue since 2009 version,but when I use old version,It's working fine.

Can anybody try it these address I put on to see if it works? Thanks.
Ken in Regina
Here's what I get in Streets 2010 using the search box in the "Search and Location" toolbar:

When I search "1800 eglinton ave e" without specifying either the city or province in the search box I get two hits, one in Mississauga and one in Toronto.

When I search "30 seneca hill dr" without specifying either the city or the province I get one hit, in Toronto.

When I enter "1800 eglinton ave east, toronto, on" in the search box I get just the Toronto selection but not the Mississauga one (makes sense when I'm that specific).

When I enter "30 seneca hill dr, toronto, on" in the search box I don't get the "Find" results box at all. Instead, it places a pushpin on the map in the correct location and has the address in the label balloon.

...ken...
Marvin Hlavac
Jackyca, you may be experiencing an issue that has been discussed here just over a year ago. It's a 5 page long thread, if you wish to read it all: http://www.laptopgpsworld.com/706-unable-find-canadian-addresses-microsoft-streets-trips

Solution seems to be posted close to the bottom of page 4, which I quote here for you:

Quote:
Originally Posted by yeek
The root cause of this problem is the setting in "Regional and Language Options" --> "Advanced" ---> "Language for non-Unicode Programs"

Due to the nature of my work, I need to run Programs with Asian characters. So, this option was set to Chinese (Taiwan). Once this is changed back to English, it works again.

I have reproduced the error on a few machines.
It is an interesting issue indeed. Let us know if you manage to correct it with the above method.
jackyca
Hi Marvin,Thanks for you kindly information,really helpful.yeah.I used unicode as well, same thing happened.
after I changed back to English,it's working just fine. when I change to with unicode support,system pops up said please maker sure spelling correctly something again.

When I use streets trips 2007 working fine with Unicode support.
after 2009 it's not support unicode properly.
Is there any solution support unicode with latest edition at same time?
jackyca
Yeah, It looks like this uni-code issue happened since 2008 edition.
Hope we can inform Microsoft Streets Trips support team, this one should be fixed.
Marvin Hlavac
jackyca, I'm glad the "fix" suggested by yeek helped you. I posted a link to this thread to http://www.laptopgpsworld.com/749-tips-tricks - it may help other Streets & Trips users in the future.
laptopgpsworld.com About