HomeGarmin


Custom POI's icons in Garmin Mobile PC
malaki86
Ok - I got my Mobile PC installed and love how it looks so far. Now for the questions to begin:

Using the POILoader, I imported a set of truckstop POI's - named Flying_J.GPI. I also have a 16x16 bmp icon named Flying_J.BMP. Both files are in the mobilepc/poi directory. Using the search, I can find any of them I want. However, I can't see any of the icons on the map in the Browse Map view.

Any ideas?
Ken in Regina
Get in the general area of one of them and zoom until you see an icon at that location. Custom POI icons don't show at the same zoom level as the builtin ones. You need to zoom at least one more level tighter. At least that's the way mine work.

Once you see the icon, is it your custom icon or a generic one?

I'm not sure how Mobile PC handles associating custom icons with custom POIs. I'll have to play with that a bit and see if I can figure it out.

Did you load them from a GPX file? If so, what does the symbol <sym> argument say?

...ken...
malaki86
The custom poi sets are gpi's. I've zoomed to the tightest zoom level and still can't see any poi icons - builtin or my own. The map detail level setting is set to most.
Ken in Regina
Can you get a Flying-J GPX file? I would like to take a look at both the GPI and GPX files if you can get links to them for me.

...ken...
malaki86
The only thing that was available for download was the csv file. I loaded that into mpc with poiloader.
Ken in Regina
I have discovered that the GPI file is the file that POI Loader creates. That's not interesting because it's not the file with the original data in it and it's not readable as text.

The CSV file contains the original data that POI Loader is converting from. That is interesting because it contains text that I can read and see what information is included with each POI. In particular, it might contain a symbol reference. That might help figure out what is happening.

...ken...
Ken in Regina
Sorry about all the noise in here. Looks like this might be your answer. If this doesn't work I'm at a loss to help further:

Creating Custom Icons For Garmin Points Of Interest (POI) | Free Geography Tools

Okay, I tested it and that works.

The key is to make sure the .CSV file and the .BMP file are the exact same name and in the same folder BEFORE you run the POI Loader. It does not do any good putting the icon file into the ...\POI folder with the .GPI file. It has to be in the folder with the .CSV file before you convert with POI Loader.

...ken...
tcassidy
Did you turn them on under Settings - Map - Map features - POI?

Terry
Ken in Regina
Quote:
Originally Posted by tcassidy
Did you turn them on under Settings - Map - Map features - POI?

Terry
Settings don't appear to have any effect on Custom POIs. I tried small, medium and large labels and it still doesn't show the labels until you click on them in browse map.

Also, the icons don't show up until you're zoomed to 50metres no matter what you set the Details setting to.

Phooey, another bug to report to Garmin. Perhaps it will be fixed in 5.00.999. Anybody seen any sign of 5.00.70 yet???

...ken...
tcassidy
Also check they are enabled in Settings - Proximity Points - Custom POI Sets.

Terry
Ken in Regina
Quote:
Originally Posted by tcassidy
Also check they are enabled in Settings - Proximity Points - Custom POI Sets.

Terry
They are/were. It appears to be the default.

...ken...
tcassidy
Quote:
Originally Posted by Ken in Regina
Settings don't appear to have any effect on Custom POIs. I tried small, medium and large labels and it still doesn't show the labels until you click on them in browse map.

Also, the icons don't show up until you're zoomed to 50metres no matter what you set the Details setting to.

Phooey, another bug to report to Garmin. Perhaps it will be fixed in 5.00.999. Anybody seen any sign of 5.00.70 yet???

...ken...

Oops. It sure sounded like it should work!

Terry
malaki86
Ok - I just imported a new set of POI's into Mobile PC using POILoader. I had the icon BMP file named exactly the same as the CSV file.

After I imported them, I went to add one of the new POI's. I searched the city it was in, selected the POI file, and it found it. It even showed the correct icon in the small map window. After seeing that, I went to the 'Browse Map' view. I zoomed in on the exact same location, down to the absolute closest zoom level and it never shows the icon.

Doing something wrong here?
Ken in Regina
Go to Settings > Map > Map Features > POI and make sure that it's not set to OFF.

...ken...
malaki86
It's set to "Medium Label"
laptopgpsworld.com About