HomeMicrosoft


Unable to add pushpins to a Streets & Trips 2010 file
LineChaser
After my road trip this weekend, I went to start updating my map, but Streets & Trips will not let me add a pushpin. Oh joy. I think this is about where I ran into dataset corruption when I had this file in S&T 2008.
Marvin Hlavac
LineChaser, because you are talking about the new version 2010, it is possible the file is NOT corrupted, and everything is just perfectly fine, only your pushpinset(s) have been hidden.

Open the Legend & Overview pane, right-click your pushpinset(s), and select 'Show'.

Then try to place a new pushpin on your Streets & Trips map.
LineChaser
Nope. That's not it.

Hid all the pushpins and then tried showing them all again. No dice. When I go to add a pushpin and try tacking it to the map, it goes back to the arrow cursor.

I think when I ran into this in the past, I created the pin on a blank map then cut / pasted it over - not long after that, I would see the dataset corruption...
SpadesFlush
LineChaser, what do you mean "no dice"? Are you saying that no pushpins show when you have selected "Show all pushpin sets"? Or are you saying the pushpins show but you still cannot add a new one? Don't forget that new pushpins will be added by default to a set called "My pushpins" even if it is hidden.
LineChaser
Pushpins all shown but still can't add pins.
Marvin Hlavac
Quote:
Originally Posted by SpadesFlush

Don't forget that new pushpins will be added by default to a set called "My pushpins" even if it is hidden.
That may be the answer. The 'My Pushpins' has to be set visible. If the 'My Pushpins' set is hidden, new pushpins you place manually on the map will not be visible.
SpadesFlush
OK, you have pushpins visible and it still won't add new ones. I am not sure it matters but did you do a "Show all pushpin sets" or did you go through each set and do "Show pushpin set"? Whichever you did, I would now try the opposite.

Looking closely at the cursor when dropping the pushpin onto the map, does it do a little splash, or starburst, as it converts the cursor icon from your selected pushpin to the default arrow? It does that for me if I create a new pushpin that gets added to a hidden set.

If none of the above, how would you feel about sharing the file, either broadcast on the Forum or as a PM attachment to Marvin or Larry? Their vast experience might help.
LineChaser
Alrighty. It's attached. I'm trying to add a black tack (not pushpin) at the corner of 1st / Dakota in Wahpeton, ND (to signify the location of a long-gone power plant).
Attached Files
File Type: est map.est (906.5 KB)
Marvin Hlavac
LineChaser, your original suspicion that the file was corrupted was likely correct. The only way I'm able to add new pushpins to your project is if I first copy your pushpin sets (Legend & Overview pane, Ctrl-G) from your file and paste them to a new Streets & Trips file.
SpadesFlush
I tend to agree with Marvin.

I can replicate your (negative) performance although I have not yet figured out why it is happening.

I find that if I copy each of the pushpin sets and paste them on to the new file, I can then add a new pushpins. Of course, the pin symbols are all the default but that is easy to change.

Therefore, I think it has something to do with the colored lines you have added. I don't know which one(s). I have cut and pasted a few from the source file to the new file, and I am still able to add pushpins. That is not super-hard to do if you have files open in 2 windows side by side, just a bit tedious.
SpadesFlush
I have now cut and pasted all your old data, LineChaser, from your old map file to a fresh file ("Map 1 c" attached) and it seems to be functioning fully, especially accepting new pushpin adds. Therefore, I conclude there was some form of corruption in your old file.

I believe the new file is pretty true to the original but you might want to check it in detail.

I am enclosing the file as you posted it but with the freeform additions all removed ("Map 11") and you can see it still will not accept pushpins so I do not think we can blame it on the freeform additions.
Attached Files
File Type: est map 11.est (864.0 KB)
File Type: est map 1 c.est (677.0 KB)
Larry
Ha ha! SpadesFlush - I have done the same thing...proof that you'll often get more help than you require on this forum.

The strange corruption easy enough to fix by either exporting to GPX and re-importing or copying the pushpin sets to a new map and back. I am more interested in how to get a saved map into this state from scratch.

Attached is my fix for you map.est - only added bonus is some new custom pushpins (from the 2006 set) which may come in handy.
Attached Files
File Type: est map.est (915.5 KB)
SpadesFlush
Well that ought to cinch it!

One thing I do not understand is why my Map 1 c file is smaller than either of yours....?.....
Larry
I am guessing it is becuase I added some extra custom pushpin images
Attached Images
extrabonusiconimages.jpg  
LineChaser
Quote:
Originally Posted by Marvin Hlavac
LineChaser, your original suspicion that the file was corrupted was likely correct. The only way I'm able to add new pushpins to your project is if I first copy your pushpin sets (Legend & Overview pane, Ctrl-G) from your file and paste them to a new Streets & Trips file.
And not long after that is where I would run into corruption in the data sets.
laptopgpsworld.com About