HomeGarmin


Problem with the nRoute registry. Please re-install and start again.
gahi
I can't get it to open. It says there is a problem with the registry, and to re-install.

Quote:
There is a problem with the nRoute registry. Please re-install the nRoute and start it again.
I've re-installed Garmin nRoute twice now, and also did a fresh download in case my copy got messed up. Any ideas?
tcassidy
Do you have MapSource installed? nRoute won't install without it.

Terry
gahi
I do, it was working fine, then just stopped. Nothing changed that I know of.
tcassidy
I believe you have Windows 7 64. Just in case, you could try starting it as administrator (right click and choose 'Run as Administrator').

Terry
gahi
I'm on Vista 64, but I did try running as admin, too. Just tried Mapsource again and its fine. I also un-installed, restarted the computer, and re-installed. Still the same message.
Boyd
I have used nRoute a lot on Vista 64 with no issues and no need to run as administrator. I've seen this error before when I was messing around trying to install/remove some of my own maps before I understood the correct way to do things.

Did this problem start after installing or removing a map? I am pretty sure that the registry error is related to one of your maps and not the program itself. Ken just posted a link to what appears to be a very cool program. You might try the repair function here for starters (have not tried any of this myself however): http://www.laptopgpsworld.com/4541-move-garmin-maps-different-location

Quote:
Repair

JaVaWa GMTK checks the maps extensively and reports errors when found. Faulty maps are coloured red in the overview. Via "Info" you can see what is wrong and whether they are repairable.

JaVaWa GMTK performs an exhaustive check and can find errors in maps that appear to work correctly in MapSource (but might not work in a future version of MapSource or BaseCamp).

JaVaWa GMTK can repair some of those errors, like double or wrong map IDs or incorrect registry settings.
When two or more maps have the same ID JaVaWa GMTK will assign new and unique IDs, but only to maps that are not locked.
Normally, I would try to troubleshoot a problem like this with mapsettoolkit, but that gets more complicated...
tcassidy
I have Vista 32 and tried installing nRoute with no problem. A quick look in the registry shows virually every nRoute entry at HKCU\Software\Garmin\nRoute and subfolders of that. An uninstall of nRoute didn't remove any of them. Maybe you need a registry cleaner to remove those entries after an uninstall. Then reinstall.

Terry
gahi
I'll try pulling off the last maps added. Where do I find the registry?

Thanks for the help guys.
gahi
Boyd, thanks for the link, I installed and ran the program, removed the two problem maps, and now I'm back in business. SWEET!

Thanks again!
Boyd
Great, glad that it worked.
gahi
I had erased some old maps, and like Tcassidy said, they must not have been completely removed. The program found the traces of them and removed them completely.
Boyd
This is the problem I suspected in my earlier post. You can't just delete map files because registry entries are involved and it will confuse Mapsource/nRoute. Typically, maps are installed just like programs. If you want to delete one of them, go to the programs and features control panel and uninstall it.
werdnanostaw
<edit>Moved here from another location</edit>

Just one day before we leave for our 4 month trip to Europe I have started getting the following error when I start nRoute:

"There is a problem with the nRoute registry. Please re-install the nRoute and start it again."

I have reinstalled Training Center, MapSource and nRoute and all of my maps without success.

There are 7 hits in Google on the first sentence but none of them offered a solution.

Any suggestions please on how to fix this?

It is too close to departure to attempt to rebuild the PC.

If all else fails I will have to run nRoute in a virtual PC.
werdnanostaw
I have tried running as administrator and in a new user account I created.
werdnanostaw
Fixed.

I tried to run MapSource and it told me there was an error with Srbija Topo 20 ver. 0.99.

I had installed a map called Srbija Topo 20 ver. 0.99.

As it's name implies it is topo data only with no towns or roads.

I had deleted it using the uninstall program that came with it. I had also deleted the install program from my HD. Luckily I hadn't deleted it off my backup drive and I was able to reinstall it.

If I hadn't tested nRoute before departure and found that it wasn't working before we left the country I would have been in deep trouble as we will be using nRoute with OSM maps throughout Eastern Europe and Turkey where MS AutoRoute doesn't have coverage.

As an aside, is there any way to superimpose the topo data over the OSM map of Serbia?
laptopgpsworld.com About